Author Topic: MED400X2S - Error "invalid file" for all videos since firmware 2.0.7  (Read 5074 times)

Offline the Core

  • Newbie
  • Posts: 1
  • Helpful Contribution Status: +0/-0
Dear forum contributors

TL. DR; How to hard reset the MED400X2S to factory defaults?

Error message "invalid file"
The MED400X2S of a friend of mine gives the "invalid file" error for all video files from a hard drive or from the network. Nothing happens after this message. Music files do play however. The video files are also being displayed with the audio icon.

This happens since firmware version 2.0.7
The problem occurs consistently for a couple of weeks. I guess it's since the update to firmware version 2.0.7 at May 2nd. A soft reset doesn't work. I've tried that multiple times. I also turned on and off the HDMI auto settings and some others video settings. Nothing helps.

Hard reset
I can't figure out how to hard reset the device. The manual says I should unplug and replug the power cable and then hold the on/off button for 15 seconds. I've tried, but the Mede8er just starts or shuts down completely. Most of the time the led just turns blue and the mede8er starts. I've tried any alternations of resetting.

I think something went wrong with the firmware 2.0.7. of the MED400X2S. Does anyone know how to reset it to factory defaults? Do more people have this issue? I hope you can help.

Kind regards,

PS: because this device isn't mine, I can't access it very often.

Offline jer1956

  • Global Moder8or
  • M8er Addict
  • *****
  • Posts: 17 391
  • Helpful Contribution Status: +201/-55
Re: MED400X2S - Error "invalid file" for all videos since firmware 2.0.7
« Reply #1 on: July 24, 2015, 06:43:38 PM »
reset to factory dosnt change back to the original firmware.  you have to reinstall that manually like any other firmware.